Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #91
    jacob_smith
    Participant

    This is an error I got on production while trying to deploy my Laravel Application. This is my the first time I deployed the App

    SQLSTATE[HY000] [1045] Access denied for user ‘forge’@’localhost

    Server: Digital Ocean
    Server Management: Forge

    What I did so far:

    (1) Run php artisan config:cache
    (2) Configure a database on Forge and then and then change the DB_Name in the ENV file to the name of that configured database

    None of those two works

    • This topic was modified 1 year, 5 months ago by jacob_smith.
    • This topic was modified 1 year, 5 months ago by roel.
    #93

    SQLSTATE[HY000] [1045] Access denied means you don’t have the right credentials for your database username and password in your ENV files.

    Please double check the credentials emailed to you when you configured your server in Digital Ocean

    “Server Provisioned
    Congratulations on your new server! We can’t wait to see what you build next.

    Remember, before you can access your server, you will need to add a public key via the Laravel Forge server management page. For added security, password authentication over SSH is disabled by default on all Laravel Forge servers and should not be re-enabled.

    Server Details
    Name: digital-ocean
    IP Address:
    Private IP Address:
    SSH Port:
    Username:
    Sudo Password:
    Database Username:
    Database Password:

    Click Environment on your Laravel Forge. That is your ENV files. Please your that

    DB_USERNAME = Database Username
    DB_PASSWORD = Sudo Password

    #96
    jacob_smith
    Participant

    Using the Sudo Password. Thanks

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.