Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #583
    dan
    Participant

    your requirements could not be resolved to an installable set of packages

    – Root composer.json requires openai-php/client ^0.6.4 -> satisfiable by openai-php/client[v0.6.4].
    – openai-php/client v0.6.4 requires psr/http-client ^1.0.2 -> found psr/http-client[1.0.2] but the package is fixed to 1.0.1 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.

    #584

    it seems that the psr/http-client version in your laravel app is not updated… openai-phpclient requires 1.0.2 but you have 1.0.1 on your sytem. You can do two things

    You can do

    (1) composer require openai-phpclient:*

    That will install a version of openai-phpclient that will fit to the version of package dependencies that already exists on your system.

    Pros: No risk since you are using an existing version of package dependencies
    Cons: Might not be the latest version of openai-phpclient

    (2) Composer update psr/http-client to the latest version

    Pros: You get to install the latest version of openai-phpclient
    Cons: the update on psr/http-client might cause breaking changes to your update specially if the latest version you updated it to has major changes in the code base

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.